Talk:Lamobo R1

From linux-sunxi.org
Jump to: navigation, search

Tried to upload a newer version of File:Addon_Board_on_Lamobo_R1.JPG (should be this version: [1]) but this does not seem to work. Always the old revision pops up again. What to do? Tkaiser (talk) 18:55, 23 June 2015 (CEST)

The same thing happened to me yesterday while trying to update [2]. We've been discussing that on IRC, and it looks like a problem with redundancy / caching on cloudflare - leading even to possible inconsistencies between linux-sunxi.org and sunxi.org ([3]). There seems to be no easy way around that, expect for actually uploading a "new" file and using that instead. --- NiteHawk (talk) 09:09, 24 June 2015 (CEST)
Thx for the explanation. I simply uploaded the image again and adjusted the link. Tkaiser (talk) 11:12, 24 June 2015 (CEST)

Fedora ARM 22 - From scratch

We are wanting to build a router based on Fedora ARM 22 from scratch and provide a step by step guide to get items off the web rather then depend on a pre configured image that may have issues .

We started off with the BPI-R1 board and Fedora-Minimal-armhfp-22-3-sda.raw.xz using the manual process mentined here. Fedrora ARM F22 Manual Install. We know that the B53 "switch" chip needs swconfig to connect via the Ethernet ports. So out of the box those works are out of bounds temporarily. So we tackled the wlan0 port and used iw to link to an access point. The R1 links up perfectly but we were not able to get an IP via DHCP or make a manual IP to work. Any help is greatly appreciated.

Gentoo image - from scratch

I have the same problem as described above: i need to run lamobo r1 with kernel 4.4. I have mainline kernel compiled and u-boot (mainline) as described here http://linux-sunxi.org/Mainline_Kernel_Howto and here https://linux-sunxi.org/Mainline_U-boot and i can not make b53 to work. I can see in dmsg that kernel is recognizing switch but i can't obtain ip from dhcp! I took patches and config from here http://linux-sunxi.org/Lamobo_R1#Manual_build. Help please :) - i can not update my gentoo :) (update reguires kernel 4.4.x)

Solution here: http://forum.lemaker.org/forum.php?mod=viewthread&tid=23248&extra=

Personal tools
Namespaces

Variants
Actions
Navigation
Tools